お客様各位
平素はlogiecをご利用いただき、誠にありがとうございます。
2025年3月31日11時~14時頃弊社システムの一部に不具合が発生しており、正常にご利用いただけない状況が続いておりました。お客様には大変ご不便をおかけしており、誠に申し訳ございません。
尚、2025年3月31日午後14時30分時点で、復旧作業が完了いたしましたのでご報告いたします。
システム障害に関する経過報告
- 障害の概要
- 発生日時:2025年3月31日10時00分頃(日本時間)
- 障害内容
大量データ処理を行った際、データベースの負荷が急激に上昇したことにより、logiecの全機能が一時的に使用できない事象が発生しました。特に入荷実績登録と出荷指示の更新に関する処理が競合し、システムの応答が著しく低下しました。この影響により、以下の機能に遅延が発生しました。
影響範囲- 対象サービス:logiecの全サービス機能
- 影響時間:2025年3月31日10時00分~14時30分
- 影響内容:上記機能の応答遅延および一部機能の一時的な停止
- 解消日:2025年3月31日14時30分頃
データベースの負荷原因となっていた一部機能(ダッシュボード機能)の一時的な制限により、システム全体の応答速度が回復しました。
- 時系列
2025年3月31日-
- 10時00分頃: システム全体の応答速度低下を検知
データベースサーバーの負荷上昇を検知 - 12時04分頃: システム負荷軽減のための対策実施
- 13時18分頃: お客様向けにシステム障害の告知を実施
- 14時19分頃: システム負荷軽減のための緊急対応実施
- 14時30分頃: システムの応答速度が正常値に回復
- 10時00分頃: システム全体の応答速度低下を検知
-
- 発生原因
複数の負荷がかかるデータ入出力処理が同時に実行されたことで、データベースサーバーの処理能力が限界を超える状況が発生しました。その状態で画面表示の処理速度悪化によるダッシュボードの再読み込みが繰り返され、結果的にシステム全体の応答速度が著しく低下しました。 - 実施内容
-
- 実施済の対応
- システム負荷軽減のため、一部機能(ダッシュボード機能)の一時的な制限を実施しました。
- 実施済の対応
-
- 今後の対応予定
- 短期的対応
- ダッシュボード機能の改善と最適化
- データベース処理の負荷分散対策実施
- 中長期対応
- 大量データ処理時の負荷分散システムの導入
- システム監視機能の強化と最適化
- 定期的な性能検証体制の確立
- 短期的対応
- 今後の対応予定
なお、今回の事象に関する詳細な原因究明と再発防止策の実施を進めております。引き続き、お客様にご安心いただける運用を目指してまいります。
ご利用のお客様には多大なご不便をおかけしましたこと、深くお詫び申し上げます。
コメント
0件のコメント
サインインしてコメントを残してください。