このエラーメッセージが表示された場合、CSVの内容を修正し再アップロードすることでエラーを解消することができます。
※カートシステムから出力した後のCSVを修正しますので、カートシステムの情報は変わりません。
必要に応じてカートシステム側の情報修正をお願いいたします。
下記のエラーメッセージが表示された場合、CSV または API 連携されたアップロードデータ内に、既定値外の値が設定されている可能性がございます。
<原因>
アップロードデータ内に、規定値外の値が設定されている
<チェック事項>
-
配送サービスマスタに登録されている文字列か?
※完全一致する必要があります。 -
データ内に不要な記号や文字列が含まれていないか?
※全角・半角スペースが文字列の前後に入っている可能性があります。
<対処方法>
- エラー内容を確認します。
例の場合、「464行目と466行目の項目名 [配送時間帯コード]」が規定値外の値に設定されていることがわかります。
- 対象のアップロードデータ(販売チャネルとCSV)を確認します。
CSVは「行数」の右にあるボタンからダウンロードします。
※データの連携方法がAPI連携であっても、ここからダウンロードし、
CSVを直接修正して再アップロードが可能です。
- logiecのマッピングを確認し「支払方法」に紐づけられている項目を確認する。
【logiecマッピング確認方法】
1)logiecにログインし、設定>マッピングをクリックする。
2)出荷指示ヘッダ>販売チャネルを選択
3)「配送時間帯コード」をCtrl+Fで検索>紐づけ項目を確認
例)今回は「[109]shipping_time」が紐づいているのでCSVの109列目を確認する
※「CSV項目名」がアップロードするCSVの1行目になっています。
[]内の数字は列番号を表しています。例)[1]=1列目、[2]=2列目...
- CSVファイルを開き、紐づいている項目の文字列が配送サービスマスタに登録されているかを確認します。
例)今回は[109]shipping_timeが該当する
(464~465行目でひとつの受注、466~469行目でひとつの受注になっています)
※API連携の場合、連携元のシステムより対象データをご確認ください。
- 対処方法4で確認した箇所を修正します。
例の場合、配送時間帯が空白になっています。
<空白が正しい場合>
配送サービスマスタに空白が登録されていないのでエラーになっています。
空白が該当する配送方法の「編集」ボタンを押下します。
「配送時間帯判定 」の該当する時間帯に空白を登録します。
<空白が正しくない場合>
正しい配送時間帯を、配送サービスマスタに登録されている文字列を参考にCSVへ入力する(コピーアンドペーストがおすすめです)
※CSVファイルをExcelなどで修正する場合は自動的に文字が変換されるケースがございますので、
十分ご注意ください。
【修正前】
【修正後】※画像は、CSV専用エディタを使用しています。
※1受注全ての行に同じ支払方法を入力してください(例では464行目・465行目が同じ受注です)。
<「配送サービスコードは配送サービスマスタに存在する値を指定してください」も同時発生している>
画像のように、上記エラーも同時発生している場合は配送サービスマスタに配送方法が登録されていません。
その場合は下記マニュアルをご確認ください。
配送サービスコードは必須です。(エラーコード:LOGIEC-ERR-0005)
5. 再度アップロードを実施の上、同じエラーが発生していないかご確認ください。
【再アップロード方法】
出荷>出荷指示アップロード>販売チャネル選択>修正したCSVを添付
>上書きモードに☑>アップロード
※上記の手順にて対象方法を実施してもエラーが解消されない場合は、
こちらからお問い合わせください。
-end-
コメント
0件のコメント
記事コメントは受け付けていません。